
ECSE-4770 Computer Hardware 
Design: 7489 Quartus II Tutorial 
Prepared By: Joe Ebel 

Introduction: 

The purpose of this tutorial is to demonstrate how to create and use a RAM in Quartus II 
and download a design to an FPGA board. First we will cover the creation of a custom RAM 
using the MegaWizard Plug-In Manager. Next, we will create a memory file to initialize the 
values stored in the RAM. We will then create a test bench and simulate the memory using the 
waveform tool. Finally, we will assign FPGA pins to the RAM, run the auto-router tool, and 
download the design to the FPGA board. This tutorial was prepared using the 13.0sp1 version 
of Quartus II Web Edition. 

Tutorial: 

1. Begin by creating a new project in Quartus. Remember that the Computer Hardware 
Design labs use the Altera DE2 board, which uses the Cyclone II EP2C35F672C6 
FPGA IC. Name the project “RAM_7489_Test” and save it in a convenient location.  

2. Create a new Block Diagram/Schematic File. Go to File > Save As and save the 
schematic file. Quartus should automatically rename the file from “Block1.bdf” to 
“RAM_7489_Test”.  

3. Select Project > Set as Top-Level Entity while “RAM_7489_Test.bdf” is open to set it 
as the top-level entity. Alternatively, you can right-click the file “7489_RAM_Test.bdf” in 
the “Files” tab of the Project Manager and select Set as Top-Level Entity.  

 

 

 

 

 

 

 

 

 



4. Double-click on the schematic to open the symbol selection tool. Choose the 
MegaWizard Plug-In Manager as shown in the following screen. 

 
 

5. You get a pop-up window where you can create a new custom design or edit an existing 
design. Choose New and click Next. 
 

 
 



 
6. You now get a new screen which has many library functions in the left pane. For this 

tutorial example, we are going to build a Random Access Memory block. Select the 
“RAM: 1-PORT” option, and enter the name RAM_7489. You may select different 
hardware description languages for the output file. To stay consistent with the rest of the 
course, we will chose VHDL. Ensure the Cyclone II family is selected and click Next. 
 

 
 



7. On the next page, enter 4 bits for the data bus width and 16 words for the memory size 
to stay consistent with the 7489. Click Next.

 
 

8. On the next page, notice that the ‘q’ output port as well as all of the input ports are 
registered. This means that any data at these ports will be read in on the rising edge of 
the clock, unlike the 7489 which reads immediately. Click Next. 

 



9. For now, we will leave the memory blank. Click Next. 

 
 

10. Click Next again on the EDA window. 

 



11. Click Finish to finish creating the RAM component. You may see a dialogue informing 
you that a Quartus II IP File has been generated and needs to be added to the project. 
Click Yes to add the file. 

 
 

 
  



12. You should now see the symbol for the RAM we just created. Click OK and place the 
RAM in your design. 

 
 

13. We now want to initialize the memory contents of our RAM. There are a few different 
ways to do this. We will use a Memory Initialization File (.MIF). Select File > New from 
the menu and then select Memory Initialization File. Click OK. 
 

 
 
 



14. Upon clicking OK, a pop-up menu will prompt us for the size of the memory file. Select 
16 words and 4 bit word size to match our RAM block. 
 

 
 

15. You can now fill the memory with any values from 0 to 15 (15 is the maximum because 
our word size is 4 bits). Right clicking on a cell or range of cells will allow us to rapidly fill 
multiple memory addresses with custom values. Select File > Save to save the .mif file. 
The file name should default to “RAM_7489_Test.mif”. 

 
 

16. Now we must update our RAM to initialize itself to our memory initialization file. Right 
click the RAM component in the schematic and select MegaWizard Plug-In Manager. 

 



17. Click Next until you reach the Mem Init tab (or just click the Mem Init tab). Select yes to 
specify a file and then select browse and find your .mif file. You may have to change the 
extension in the file explorer window from .hex to .mif to see your .mif file. Select the file 
and then click Finish. Click OK on the file overwrite warning and Yes on the Symbol 
update request. It does not matter which update option you select as there is only one 
affected RAM component in our design. 
 

 
 

 

 
 



18. We are now ready to wire our RAM to pins for simulation. Notice that the data, address, 
and q pins contain 4 signals. Use the orthogonal bus tool to draw a bus from each of 
these pins. The bus will look thicker than a signal wire. From the data and q busses, 
connect four individual signal node wires using the orthogonal node tool. Also add a 
signal wire for the wren (write-enable) and clock pins. 

 
19. In order to tell Quartus which signal in the bus our signal lines connect to, we have to 

name the signal lines and the bus following a specific naming convention. To name a 
signal node or bus, select the node or bus, right-click and select properties, and then 
enter a name for the node or bus. You may also simply select the signal node or bus and 
start typing a name. Name the data bus “Data[3..0]” following the naming convention in 
the RAM block symbol. We will then name our signal nodes “Data[3]”, “Data[2]”, 
“Data[1]”, and “Data[0]”. Quartus II will then know that the Data[3] node connects to the 
first signal in the data bus, Data[2] to the second signal in the data bus, and so on. 
Name the rest of the signals following the same convention. 
 

 



 
20. Now we must add input and output pins to our design. Double click to open the symbol 

place dialog and find the pins in the c:altera > primatives > pin folder. Use repeat-
insert mode to quickly place multiple pins. The address bus uses a standard input pin. 

 
 

21. Make sure all input and output pins are named. Avoid characters that are not 
alphanumeric when naming pins (underscores are OK). For the address bus, we must 
use the AHDL naming convention “ADDR[3..0]” like we did for the bus. Name the rest of 
the signal node pins D0, D1, D2, etc. as shown below. 

 
 



22. We are now ready to compile and simulate our design. Go to Processing > Start 
Compilation and compile your schematic.  

 
19. Go to File > New and create a new University Program VWF. This option is under 

“Verification/Debugging Files”. Right-click on the bar in the left side of the screen to 
bring up a menu. Select “Insert Node or Bus. . .”. In the window that opens, select 
“Node Finder. . .” and switch to the Node Finder window. Click the “List” button to 
import all I/O nodes from the schematic. You will notice that the ADDR nodes are listed 
individually and as a group. We only need the group. Press “>>” to select all nodes and 
then highlight the ungrouped ADDR nodes in the “Selected Nodes” list and press “<” to 
deselect them. Press “OK” on the Node Finder and “OK” on the “Insert Node or Bus” to 
finish importing the nodes.  

 



 
21. The box on the left side of the window will have the nodes out of order. Notice that the 

ADDR signals are grouped together while the Q and D signals are not. Click and drag 
the signals up and down to rearrange them. Arrange the DX signals next to each other in 
descending order, shift and click to select all 4 signals, right click, and select Grouping > 
Group to group the signals together. Give the signal group a name (like “DATA”) and 
click OK. Repeat for the signals in the Q bus. Ensure that the MSB (index 3) for each 
signal is the first signal listed in the group. If the signals are backwards, right click the 
group and select “Reverse Group or Bus Bit Order”. 
 

  
 

 



22. We are now ready to set up our inputs for the simulation. First we will set up a clock 
signal. Select the clock signal by clicking on it and then select the “Overwrite Clock” icon 
in the menu tray. Click OK on the pop-up dialog to create a 10 nS clock with 50% duty 
cycle and no offset. 

 

 
 

 
 
 



 
23. Now we want to increment the address so that we can read out the contents of our 

memory. Select the address group and then select the “Count Value” icon in the menu 
tray. In the pop-up dialogue, set the count transitions to occur every 40 nS and click OK. 
The address signal group should now count up every 40 nS 
 

   
 

 
 

24. Go to Simulation > Options and set the simulator to “Quartus II Simulator”. This will 
have to be done every time this waveform file is opened. The program will open a 
warning dialog box. Press “OK” to ignore it. Then, go to Simulation > Run Functional 
Simulation in order to simulate the circuit behavior. The program will ask you to save 
the waveform file. Then, the simulation results will open up in a separate window.  

  



24. Check your results against the sample results below. You should see that the Q output 
matches the data values we stored in the RAM using our memory initialization file. 
Notice that the output is updated on the second rising edge of the clock after a new 
address is presented to the RAM. This is because we selected to register both the input 
and output ports of our RAM in the MegaWizard Plug-In Manager. On the first rising 
edge, the RAM receives whatever address is presented at the address pins. The RAM 
reads the data value and presents it to the output port, but the data at the output port is 
not presented to the Q pins until the next rising clock edge. 

 
 

25. We are ready are ready to set up our design to download to the DE2 board. The board 
details can be found in the DE2 user manual (NOT the DE2-115). The manual does not 
exist on Intel’s website, but it can be found on numerous university websites: 
 
http://www.ece.tufts.edu/~hchang/ee129-f06/project/project2/DE2_UserManual.pdf 

 



26. Before transferring the compiled binary to the FPGA board, we must assign FPGA pin 
numbers to the input/output pins of our design and run the auto-route tool. Close out of 
the simulation results and the simulation window and select Assignments > Pin 
Planner to open the pin assignment planner. You will notice the pins already have a 
fitter location. This is because we ran the auto-route tool when we compiled the design 
and Quartus II automatically selected pins since we did not tell it which ones to use. 

 
 

27. Enter the pins for the inputs/outputs as shown below by entering the pin names in the 
Location field. The pin names used for inputs are toggle switches and the pin names 
used for the Q outputs are red LEDs on the DE2 board. Pin numbers for these 
peripherals can be found in Table 4.1 (page 28) and Table 4.3 (page 29) of the user 
manual. 

 
 



28. Close the pin-planner and compile the design again to run the auto-router and generate 
the bitstream file for download to the board. 
 

29. Ensure the DE2 board is connected to your PC and powered on. Open the programmer 
by selecting Tools > Programmer from the menu. Click the Start button to transfer your 
sof file to the FPGA. Your logic circuit should now be programmed to the FPGA. To 
interface with this logic circuit, we can route logic signals to pins on the IOBanks and 
connect external wires from the IOBank pins to a breadboard. 

 
 

30. When the hardware is connected, the Start button is enabled. If the hardware is 
connected and the label next to the “Hardware Setup…” button says “No Hardware”, 
check that the USB blaster driver is correctly installed following the procedure in the next 
section. You may need to set up the Altera hardware setup (left top corner). Change the 
currently selected hardware to USB-Blaster and close the window. 

  



 
31. Check the functionality on the FPGA board. The assigned peripherals are shown in the 

following diagram. Remember that two rising edges of the clock are needed to read from 
or write to the memory we created. 
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Altera USB Blaster Driver: 

This should be already come with Quartus installation. Check the drivers directory in the quartus 
installation folder. C:\altera\13.0sp1\quartus\drivers\usb-blaster  
 

1. Plug the USB-Blaster download cable into the PC. The Found New Hardware dialog box appears.  

2. Select Locate and install driver software (recommended).  

3. Select Don't search online.  

4. When you are prompted to Insert the disc that came with your USB-Blaster, select I don’t have 
the disc. Show me other options.  

5. Select Browse my computer for driver software (advanced) when you see the Windows 
couldn’t find driver software for your device.  

6. Click Browse... and browse to the <Path to Quartus II installation>\drivers\usb-blaster 
directory. Click OK. {C:\altera\13.0sp1\quartus\drivers\usb-blaster}  

7. Select the Include subfolders option and click Next.  

8. If you are prompted Windows can’t verify the publisher of this driver software, select Install 
this driver software anyway in the Window Security dialog box.  

9. The installation begins.  

10. When the software for this device has been successfully installed appears, click Close.  

 

Miscellaneous Quartus II Tips: 

1. Connecting pins using wires in Quartus II schematics requires superhuman precision. 
You will often make mistakes that lead to unconnected pins or extra wiring. When this 
happens, press CTRL+Z to undo the wire and then try again. When you finish wiring, 
carefully look over your schematic for the small ‘x’ symbol that represents an 
unconnected pin or wire.  

2. Double-check that your selected device is the EP2C35F672C6 in the Cyclone II family. 
If you select a different FPGA, Quartus will still compile and it may load to the DE2 
board. However, it will not work.  

3. During simulations, make sure that the “Quartus II Simulator” is selected. The program 
will reset this to “ModelSim” every time you close and reopen the waveform file.  

4. If you are using the MalwareBytes Antivirus software on your computer, add “C:\altera” 
to the antivirus exclusion list. Otherwise, the AV’s heuristic detection engine may flag 
Quartus as malware and corrupt your installation.  


